Results 1 to 7 of 7

Thread:

  1. #1
    Noobie
    Join Date
    Aug 2019
    Location
    lebanon PA
    Posts
    1

    Default 2001 blast starting problem "ignition module"?

    working on a 2001 buell blast 500cc with 9,000 miles i just want to say i am very good with the mechanical end of machinery but not so good when it comes to electronics. my problem is when my son rides the bike he can turn it off multiple times and it starts back up but out of the blue it will turn over but will not start. i go to check it and it turns over but will not start. i took notice the led on the ignition module does not flash when cranking it. we leave it sit where it shuts off for various amounts of time so we can try it while it's hot, warm and cold with no start. so i load it on the truck and take it to my garage, pull it off the truck and it starts right up. this happens every time the bike don't start and i load it up and bring it home. to me this seems like just too much of a coincidence to act like this every time! as of right now the bike is unreliable and he will not ride it! the bike will run all day as long as it is not turned off any insight on this problem? am i looking at replacing the ignition module? any suggestions would be greatly appreciated!

  2. #2
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,818

    Default

    Jumper the kickstand safety switch, flip the middle diode in the fuse box and try again.
    If that still doesn't do it, clean all grounds thoroughly.
    If still having the issue after that, then replace the module.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  3. #3

    Default

    Quote Originally Posted by imgevans View Post
    working on a 2001 buell blast 500cc with 9,000 miles i just want to say i am very good with the mechanical end of machinery but not so good when it comes to electronics. my problem is when my son rides the bike he can turn it off multiple times and it starts back up but out of the blue it will turn over but will not start. i go to check it and it turns over but will not start. i took notice the led on the ignition module does not flash when cranking it. we leave it sit where it shuts off for various amounts of time so we can try it while it's hot, warm and cold with no start. so i load it on the truck and take it to my garage, pull it off the truck and it starts right up. this happens every time the bike don't start and i load it up and bring it home. to me this seems like just too much of a coincidence to act like this every time! as of right now the bike is unreliable and he will not ride it! the bike will run all day as long as it is not turned off any insight on this problem? am i looking at replacing the ignition module? any suggestions would be greatly appreciated!
    Iím having a similar issue. Did you figure it out? And if you replaced the module, where did you buy it? I canít find it anywhere, and the Harley dealership checked nation wide and nobody sells it.


    Sent from my iPhone using Tapatalk

  4. #4
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,818

    Default

    Harley sucks in general. St Paul H-D still sells Buell parts, and the ignition module.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  5. #5

    Default

    Quote Originally Posted by Jet-Lee View Post
    Harley sucks in general. St Paul H-D still sells Buell parts, and the ignition module.
    Oh theyíre horrible. Been telling me the part will be in on several different dates. Iíve check all over eBay, do you know of any other places that might sell an ignition module?


    Sent from my iPhone using Tapatalk

  6. #6
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,818

    Default

    An ignition module? Sure. A Blast ignition module? They were my go-to. I'll check my garage, but no promises, I might've sent it on already. Have you checked Buellsterparts.com?
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  7. #7

    Default

    Quote Originally Posted by Jet-Lee View Post
    An ignition module? Sure. A Blast ignition module? They were my go-to. I'll check my garage, but no promises, I might've sent it on already. Have you checked Buellsterparts.com?
    Iíll check them out. Thank you!


    Sent from my iPhone using Tapatalk

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •