Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread:

  1. #1
    Silver Supporter KennyG's Avatar
    Join Date
    Jul 2013
    Location
    North Texas
    Posts
    651
  2. Default Idle Speed on 2009 Blast

    The idle speed on my Blast is a little too fast when I fist pull into stop, but after I sit with engine idling for about a minute it returns to the correct idle speed. I recently noticed that the idle speed is faster than it ever was before when the automatic choke is on.

    Any help will be greatly appreciated.

    Kenny G
    *** 2009 Blast *** V&H Exhaust *** Dan's Intake System Along With Recommended Jetting By Dan *** Yellow Skins Purchased, New Old Stock, From Dealers Who Used Yellow Blasts For Riders Edge ***
    *** Pirelli Diablo Tire Front *** Pirelli ST 66 140 70S 16 Tire Rear***

    *** Hope To Work On Suspension Next ***

  3. #2
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,756
  4. Default

    Leaking boot (whether crack or seal) or leaking exhaust. High idle is almost always indicative of a leak at either end.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  5. #3
    Silver Supporter KennyG's Avatar
    Join Date
    Jul 2013
    Location
    North Texas
    Posts
    651
  6. Default

    Lee,

    I was afraid that it might be the boot.
    It has been on for at least 4 years.
    I have a spare boot so I will slap it on tomorrow and order another spare.

    Thanks Lee,

    Kenny G
    *** 2009 Blast *** V&H Exhaust *** Dan's Intake System Along With Recommended Jetting By Dan *** Yellow Skins Purchased, New Old Stock, From Dealers Who Used Yellow Blasts For Riders Edge ***
    *** Pirelli Diablo Tire Front *** Pirelli ST 66 140 70S 16 Tire Rear***

    *** Hope To Work On Suspension Next ***

  7. #4
    Silver Supporter KennyG's Avatar
    Join Date
    Jul 2013
    Location
    North Texas
    Posts
    651
  8. Default

    Today I changed my Super Boot and used one that I purchased from Dan quite awhile ago
    I can't tell for sure if the problem is fixed or not, but idling in the garage the fast idle with the automatic choke is extremely fast and after the choke shuts off I am getting some popping back through the carburetor until the engine is completely warmed up. I changed the spark plug and spark plug wire.

    The temp here today is in the low 30's so I will have to wait a few days to do a road test.

    Anything else I should be looking for?

    Kenny G
    *** 2009 Blast *** V&H Exhaust *** Dan's Intake System Along With Recommended Jetting By Dan *** Yellow Skins Purchased, New Old Stock, From Dealers Who Used Yellow Blasts For Riders Edge ***
    *** Pirelli Diablo Tire Front *** Pirelli ST 66 140 70S 16 Tire Rear***

    *** Hope To Work On Suspension Next ***

  9. #5
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,756
  10. Default

    Did you clean both the carb and 'manifold' with a wire brush prior to installing the new boot? Sounds like a new leak.

    Don't forget to check the exhaust for a leak as well. A bbq lighter by the head, look for any movement of the flame to indicate a gasket leak. Inspect the whole header for cracks.

    Exhaust leak creates same symptoms as intake leak.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  11. #6
    Silver Supporter KennyG's Avatar
    Join Date
    Jul 2013
    Location
    North Texas
    Posts
    651
  12. Default

    Lee,

    Thank you,

    I did clean the carburetor and the manifold with a wire brush and lacquer thinner before installing the new boot.

    I will check the exhaust before I test ride the Blast.

    Kenny G
    *** 2009 Blast *** V&H Exhaust *** Dan's Intake System Along With Recommended Jetting By Dan *** Yellow Skins Purchased, New Old Stock, From Dealers Who Used Yellow Blasts For Riders Edge ***
    *** Pirelli Diablo Tire Front *** Pirelli ST 66 140 70S 16 Tire Rear***

    *** Hope To Work On Suspension Next ***

  13. #7
    Silver Supporter KennyG's Avatar
    Join Date
    Jul 2013
    Location
    North Texas
    Posts
    651
  14. Default

    Does the Blast take the same crush washer for the header going into the head as a Sportster?

    Kenny G
    *** 2009 Blast *** V&H Exhaust *** Dan's Intake System Along With Recommended Jetting By Dan *** Yellow Skins Purchased, New Old Stock, From Dealers Who Used Yellow Blasts For Riders Edge ***
    *** Pirelli Diablo Tire Front *** Pirelli ST 66 140 70S 16 Tire Rear***

    *** Hope To Work On Suspension Next ***

  15. #8
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,756
  16. Default

    Yes, as a 1200.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  17. #9
    Silver Supporter KennyG's Avatar
    Join Date
    Jul 2013
    Location
    North Texas
    Posts
    651
  18. Default

    Thank you Lee,

    I am not getting anywhere and I can't find an exhaust leak and I still have the fast idle.

    I noticed somethin new that may indicate a problem, there is some smoke coming out of the filter Dan sells for the crankcase breather.

    Is it possible to disconnect the enrichener or automatic choke and see how the engine idle speed is?

    If the engine is warm when I first start the engine the idle speed is fine, as soon as I twist the throttle the speed does not come back down. It appears as if the idles speed stop seats against the idle speed screw and the speed is still way up....

    Am I correct in assuming this is a Kehin carburetor ?

    Kenny
    Last edited by KennyG; 11-16-2018 at 12:55 AM.
    *** 2009 Blast *** V&H Exhaust *** Dan's Intake System Along With Recommended Jetting By Dan *** Yellow Skins Purchased, New Old Stock, From Dealers Who Used Yellow Blasts For Riders Edge ***
    *** Pirelli Diablo Tire Front *** Pirelli ST 66 140 70S 16 Tire Rear***

    *** Hope To Work On Suspension Next ***

  19. #10
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,756
  20. Default

    Yes, it is a Keihin CV-40 sans accel-pump.

    That smoke is likely just condensation burning off of the oil, it happens in cold weather and is normal.

    Is your idle speed fast only when the auto-enricher is active? After about 2 minutes of power on, the AE should be completely off.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •