Results 1 to 3 of 3

Thread:

  1. #1

    Default 2007 Buell Blast white smoke coming out of carburetor after shut-off

    Hi there, I'm a new motorcycle rider and bought a 2007 Buell Blast in May of this year as my first motorcycle. I have some questions that I hope you guys can help me with.
    The Buell Blast I bought had really low mileage(1023 miles) and seemed to be running fine when I bought it. It was bone stock and even had the original tires that were cracked all over from dry rot.
    After I bought it, I replaced the tires, the boot(minor cracking on the inside), the front rubber mount(cracked). It is not a California bike so didn't have the cannister thing.
    I noticed that the motorcycle would idle fine when cold but as I ride for longer periods of time the idle speed would start to decrease until its almost stalling. I diagnosed this to be the motor getting really hot and the pcv spraying a fine mist of oil(?) into the carb and causing a rich condition so I plugged the hose going into the carb and re-routed the pcv to a breather and that seemed to have helped my idle speed. But the motor always seems to run really hot and sometimes I think I can see/smell the fine mist of oil coming out of the breather.

    Recently, I started reading about mods and so I drilled a hole in the stock exhaust and cut the divider piece in the air box and put a outerwears bootie on the outside of the airbox(and removed the original air filter). I shimmed the needle .05 and I also bought a 45 jet to re-jet the carb but turns out the previous owner already had it jetted it 45/175
    The problem I had is that when I re-jetted the carb and put everything back together, I had backed out the idle screw all the way in order to remove the carb and after I put everything back together I had left it that way so the butterfly was closed all the way.
    I then started the motorcycle and it idled really rough and then slowly died. After that I tried cranking the motor a few times to try and get it started again and the carb must have coughed and torn the boot. Anyway, I soon realized I forgot to adjust the idle screw so I adjusted it and got it started. It seemed to be runing rough but I wasn't sure if it was the exhaust mod or airbox mod so I took it out for a test ride. On my test ride the bike had no power at all, it would rev ok in neutral but when I try to drive it the bike just had no power and I limped it home about 2 miles going like 20mph. Once home I opened the intake cover and this thick white smoke comes pouring out of the intake box and it is coming from the cylinder. I then take everything apart again and check the boot and find it torn on the inside and replace it.
    Now the bike is running strong again but after riding it, if I open the intake box right after riding it I can still see a little bit of white smoke coming out from the carburetor.
    So my question is, is my bike running lean/rich? is this normal? Did I do some permanent damage when I rode it with the torn boot(must of had a huge intake leak)
    Sorry didn't mean for this post to turn into a book. Any ideas or suggestions on whether I should be concerned or not or anything else I can check? Please let me know. Thanks!

  2. #2
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Oakley, CA
    Posts
    6,738
  3. Default

    Welcome!

    White smoke is normal.

    Pics?
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

  4. #3

    Default

    Thanks for the quick reply. I went out and rode the bike around for a bit. So far seems like the white smoke from the carb has stopped. I'll keep an eye on it and try to get a video if it starts doing it again

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •