Results 1 to 8 of 8

Thread:

  1. #1

    Default Speedo/batt

    My 2005 Blast had no windscreen and I noticed that the speedo was intermittent, lights work but no needle or odometer. When I held the hand brake,the cluster would work. Then everything came back on and was working fine,for a min. then the batt. swelled ,burst,leaked and died. I've replaced the batt. and now the bike cranks but won't start. I've checked the fuses, all good. The bike is stock except for the handlebars and exhaust. Any help would be appreciated.

  2. #2
    Noobie
    Join Date
    Feb 2018
    Location
    Las Vegas, NV
    Posts
    10
  3. Default

    Has it always been this way since you bought it? Possible mods that required wire tapping from previous owner that were removed prior to sale; would be my guess as far as the speedo

  4. #3

    Default

    I bought it, running fine, I found a bad isolator but haven't figured out what is interrupting my spark. Since the batt. burst I'm thinking that he voltage reg. must not be working. There's a ground near the isolator, if that wasn't grounded , I'm thinking that's why the batt. Burst IDK

  5. #4

    Default

    Quote Originally Posted by HDfam View Post
    I bought it, running fine, I found a bad isolator but haven't figured out what is interrupting my spark. Since the batt. burst I'm thinking that he voltage reg. must not be working. There's a ground near the isolator, if that wasn't grounded , I'm thinking that's why the batt. Burst IDK
    I've replaced the front isolator, I had to heli-coil the cylinder head the braided ground is connected. The bike cranks ,all of the lights work. I've been told that b/c the batt. Burst the regulator and rectifier must be bad would that interrupt spark? Also if anyone has a link to an 05 service manual or elect. Diagram, I'd really appreciate it.

  6. #5
    Noobie
    Join Date
    Feb 2018
    Location
    Las Vegas, NV
    Posts
    10
  7. Default

    So the threads were stripped for the mounting bolt? http://buellmods.com/ Has your manual needs.

  8. #6

    Default

    Quote Originally Posted by Dylan View Post
    So the threads were stripped for the mounting bolt? http://buellmods.com/ Has your manual needs.
    Yes, I was knocked over on the expressway Doing 80,I know , I'm lucky, with a heavy leather, thick work /riding boots and a helmet I escaped w/10 stitches and road rash. I advocate protective gear!! The short mounting bolt on the side w/the braise ground pulled out and was gone. I ride the bike for a month w/o knowing then the spedo acted weird, the batt.swelled and burst. New batt. swell and burst. New batt. swell burst and now no spark.
    TY for the link. Can't wait to start thumpin' again.

  9. #7
    Noobie
    Join Date
    Feb 2018
    Location
    Las Vegas, NV
    Posts
    10
  10. Default

    Wow thankfully you're here today even after that mess.. . When I restored my bike I didnt even have the ground there as the bike was all in parts when I got it from someone else, and it took me quite a while to realize it wasnt turning over because it wasnt grounded, and I went through 3 clutch cables ( it grounds to the cable if the braided line isnt there and melts the cable lol).
    I do bet that the grounding going in and out since it wasnt fully connected was causing problems with your battery for sure. Have you tried replacing the regulator yet ? it does sound like overcharging and causing swelling. I am not sure if that interrupts spark exactly.. Have you tried the trick with turning the bike over with the threads of the plug touching the engine? You should get an arc , if not then for sure there isnt a spark. Just be careful if you do that trick as last time i did it I got a little shock lol

  11. #8

    Default

    yeah, no spark against cylinder,ty,I'm printing the no spark step by step checklist from the manuals ,ty again. I'll test the reg. during that and update.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •