Results 1 to 2 of 2

Thread:

  1. #1

    Default Ignition modual

    So I just finished going through he'll amd back getting my 01 buell blast p3 500cc running near perfect only to take her on her first ride and have it die 10min in after looking though things it appears I loose spark after warming up then after a cool down period fires back up and after alot of reading I see that it is the ignition modual but I'm having alot of trouble finding a decent modual that won't break my wallet does anyone have some links to moduals that are relative oem replacement as in not alot of modifications to install I bought the bike for 600$ the 3k miles and a clean and clear title after a 60$ kit to rebuild the carb and replacing the intake boot I'm not looking to be in it alot and so far I feel I've gotten a good deal as long as this modual doesn't ruin things

  2. #2
    The Boss
    (Admin)
    Jet-Lee's Avatar
    Join Date
    Mar 2012
    Location
    Antioch, CA
    Posts
    6,677
  3. Default

    Sorry for the late reply, Petey...been hell at home/hotel.

    Sounds like you ignition module is indeed on its way out. You should be able to replace it at any Harley dealer. Online I use New Castle HD or Surdyke.
    "It is impossible, until some crazy son of a bitch has the audacity to believe that no matter what the expert says, I can still do that shit." - C.T. Fletcher

    Click here to enlarge
    Left to Right:
    2003 Blast (Blue), 2001 XBlast (Rex), 2007 XB9R Firebolt (Bolt)

    Do you like the forum? Do you appreciate the input and community support? Consider donating to help keep us alive and growing! Click here to donate!
    Like us on Facebook!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •